Ipregistry - Incorrect geolocation data for some IP addresses in the range 64.0.0.0-127.255.255.255 – Incident details

Incorrect geolocation data for some IP addresses in the range 64.0.0.0-127.255.255.255

Resolved
Operational
Started over 2 years agoLasted about 4 hours

Affected

Dashboard

Operational from 12:35 AM to 4:32 AM

API

Operational from 12:35 AM to 4:32 AM

Globally distributed nodes — https://api.ipregistry.co

Operational from 12:35 AM to 4:32 AM

Europe nodes — https://eu.api.ipregistry.co

Operational from 12:35 AM to 4:32 AM

Updates
  • Resolved
    Resolved

    The issue is now globally resolved. If you are caching data, we suggest clearing your cache to evict invalid data.

    We apologize for the inconvenience this has caused.

    Make sure we are taking actions to prevent such an issue to happen again.

  • Monitoring
    Monitoring

    We implemented a fix. Deployment is in progress. We are currently monitoring the result. The issue should be resolved globally in the next minutes.

  • Identified
    Identified

    We identified the source of the issue. The problem is caused by an human error introduced in the data we receive from a trusted source.

  • Investigating
    Investigating

    We are experiencing an issue with the geolocation information returned for some IP addresses in the range 64.0.0.0-127.255.255.255.

    We are currently investigating this incident.