Ipregistry - Ipregistry API returns error 502 when invoked from some locations – Incident details

Ipregistry API returns error 502 when invoked from some locations

Resolved
Operational
Started over 1 year agoLasted about 2 hours

Affected

API

Operational from 3:19 PM to 5:26 PM

Globally distributed nodes — https://api.ipregistry.co

Operational from 3:19 PM to 5:26 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We have implemented a solution and are closely monitoring the situation.

    We sincerely apologize for any inconvenience this may have caused. Please be assured that we are actively taking measures to reduce the likelihood of similar issues occurring in the future.

  • Identified
    Identified

    We encountered a problem with one of our cloud service providers, despite employing multiple providers to bolster resilience and mitigate such incidents. Regrettably, a simultaneous issue with Cloudflare disrupted our backup systems:

    https://www.cloudflarestatus.com/incidents/n6r61f6mz091

  • Investigating
    Investigating
    We are currently investigating this incident.